読者です 読者をやめる 読者になる 読者になる

いろいろ試行錯誤

調べものしたときの覚書きや、仕事でコーディングした時のメモ などなど…

Eclipse3.6(Helios) → 4.2(Juno)アップ時のエラー

Eclipse のバージョンを 3.6(Helios) から 4.2(Juno) に上げた。
そしたら、☟のエラーが出た。

gae java.lang.RuntimeException: Cannot get the System Java Compiler. Please use a JDK, not a JRE.

紛らわしい JRE を全てアンインストールして、
新規に Java SE Downloads から JDK1.6 をダウンロード。
Eclipse.ini の設定を eclipse.ini - Eclipsepedia で書いてある通り、JavaVM の設定を追加。

 -startup
 plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
 --launcher.library
 plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.100.v20110502
 -product
 org.eclipse.epp.package.java.product
 --launcher.defaultAction
 openFile
 --launcher.XXMaxPermSize
 256M
 -showsplash
 org.eclipse.platform
 --launcher.XXMaxPermSize
 256m
 --launcher.defaultAction
 <b>openFile
 -vm
 C:\Java\JDK\1.6\bin\javaw.exe</b>
 -vmargs
 -Dosgi.requiredJavaVersion=1.5
 -Xms40m
 -Xmx1024m

すると、今度は☟のエラーが発生。

org.tmatesoft.svn.core.SVNErrorMessage.initCause

eclipseでSVNErrorMessage.initCauseエラー(その2) - ええやんブログの記事に従って、SVN Connectors をインストールする。
Eclipse のメニューから[ヘルプ]>[新規ソフトウェアのインストール]を選択。
作業対象に☟を設定。

Subversive - http://community.polarion.com/projects/subversive/download/eclipse/3.0/juno-site/

すると一覧に「SVNKit 1.3.8 実装(オプション)」というのがあるので、チェックしてインストール。
f:id:k-kitaoka:20130208115047p:plain

促されるがまま再起動したら上手くいきました♬