読者です 読者をやめる 読者になる 読者になる

いろいろ試行錯誤

調べものしたときの覚書きや、仕事でコーディングした時のメモ などなど…

Eclipse4.2(Juno)でPHP開発環境

Eclipse PHP

PDTインストール

f:id:k-kitaoka:20130311165449p:plain

  • PHP 開発ツール(PDT)」と「PHP 開発ツール(PDT) SDKフィーチャー」にチェックして「次へ」
  • すると↓のエラー発生
Cannot complete the install because of a conflicting dependency.
  Software being installed: PHP Development Tools (PDT) 3.1.2.201212211235 (org.eclipse.php.feature.group 3.1.2.201212211235)
  Software being installed: PHP Development Tools (PDT) SDK Feature 3.1.1.201209101312 (org.eclipse.php.sdk.feature.group 3.1.1.201209101312)
  Only one of the following can be installed at once: 
    PDT Core Plug-in 3.0.1.v201201110400 (org.eclipse.php.debug.core 3.0.1.v201201110400)
    PDT Core Plug-in 3.1.1.201209101312 (org.eclipse.php.debug.core 3.1.1.201209101312)
    PDT Core Plug-in 3.1.2.201212211235 (org.eclipse.php.debug.core 3.1.2.201212211235)
  Cannot satisfy dependency:
    From: PHP Development Tools (PDT) Runtime Feature 3.1.1.201209101312 (org.eclipse.php.feature.group 3.1.1.201209101312)
    To: org.eclipse.php.debug.core [3.1.1.201209101312]
  Cannot satisfy dependency:
    From: PHP Development Tools (PDT) 3.1.2.201212211235 (org.eclipse.php.feature.group 3.1.2.201212211235)
    To: org.eclipse.php.debug.core [3.1.2.201212211235]
  Cannot satisfy dependency:
    From: PHP Development Tools (PDT) SDK Feature 3.1.1.201209101312 (org.eclipse.php.sdk.feature.group 3.1.1.201209101312)
    To: org.eclipse.php.feature.group [3.1.1.201209101312]
  • PHP 開発ツール(PDT) SDKフィーチャー」のみチェックしてインストールすると、なぜかうまくいった